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How to install and use Ninja Strategy Loader

1. Install Setup — Ninja Strategy Loader

Please find your Setup provided when you download the product Ninja Strategy Loader (executable file).
Right click on it and select open to run.

This PC » Downloads w

]

Ninja Strategy Loader
Setup - Minja
Strateqy Loader

Open

E;' Run as administrator
Troubleshoot compatibility
Pin tn Start

1. Select Destination Folder

e Setup will be install into the default destination folder.
¢ If you would like to select a different folder, click Browse.
e To continue, click Next.

.@‘ Setup - Minja Strategy Loader —

Select Destination Location
Where should Minja Strateay Loader be installed?

Setup will install Minja Strategy Loader into the following folder.

To continue, dick Mext., If vou would like to select a different folder, dick Browse.

": rogram Files (x86)\Ninja Strategy Loader Browse. .,

At least 0.9 MB of free disk space is required.
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2. Select Additional Tasks

e Put a check on the box to create a desktop shortcut.
¢ Click Next, to continue.

@ Setup - Minja Strategy Loader —

Select Additional Tasks
Which additional tasks should be performed?

Select the additional tasks you would like Setup to perform while installing Minja
Strategy Loader, then dick Mext,

Additional shortcuts:
Create a desktop shortout

< Back Cancel

3. Ready to Install

¢ Click Install to continue with the installation, or click Back if you want to review or
change any settings.

.@‘ Setup - Minja Strategy Loader —

Ready to Install
Setup is now ready to begin installing Minja Strateqy Loader on your computer,

Click Install to continue with the installation, or dick Badk if you want to review or
change any settings.

Destination location:
C:\Program Files (x86)\Minja Strategy Loader

Additional tasks:
Additional shortcuts:
Create a desktop shortcut

< Back Install Cancel
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4. Completing the Setup

e Setup has finished installing Ninja Strategy Loader on your computer.
e Put a check on the box to Launch Ninja Strategy Loader after the setup.

¢ Click finish to exit Setup.

.@' Setup - Minja Strategy Loader —

Completing the Ninja Strategy
Loader Setup Wizard

Setup has finished installing Minja Strategy Loader on your
computer, The application may be launched by selecting the
installed shortouts,

Click Finish to exit Setup,

Launch Ninja Strategy Loader

2. Download and install Microsoft Access database engine 2010 x64 bit
https://www.microsoft.com/en-us/download/details.aspx?id=13255

Note: Download and install only if not exist in your machine.

Microsoft Access Database Engine 2010 Redistributable

select Language: EnghSh '

This download will install a set of com ponents that can be used to facilitate transfer of
data between 2010 Microsoft Office System files and non-Microsoft Office applications.

This PC » Downloads

b Name

EBAccessDatabaseEngine_X& 10/2/2017 11:51 AM __ Application 27,961 KB
Open
9 Run as administrator
Troubleshoot compatibility
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ﬂ Microsoft Access database engine 2010 (English) Setup X

Microsoft Access database engine 2010 (English) Setup has
L{]
["ji3 completed successfully.

3. Importing NPOI & SystemData DLL’s — Strategy Compatibility Tool

These are free DLL files that can be downloaded from web and are required for Ninja Strategy Loader...
should be found inside in your downloaded Setup — Ninja Strategy Loader.zip

Open NinjaTrader Control Center. Go to File > Utilities > then click Import NinjaScript.

MW Control Center - Untitled1 — O bt
File | Tools Help [+/-] Open Live Account
Mew * Bs Accounts Account Peformance Log
M Workspaces o Parameters Position Avg Unrea Reali Account Connect Enable
§ Connect 3
= Disconnect 3
Flatten Everything
AT Interface
Global Simulation Mode
W Utilities v [ Import NinjsScript..
41 it z Export MinjaScript...
3 Remove NinjaScript Assembly...
3 Backup...
| 2  Restore..

Browse the NPOI & SystemData zip file. Then, click Open to import.

MW Control Center - Untitled1 = O *
MW Import NinjaScript Archive File (.zip) ¥ fount
U <« Desk.. » Setup - Minja Strat... + O Search 5etup - Minja Strategy .. 0@ | p——
nable
Organize v New folder =~ O @
~
Load First Strat MName Date modified Type
Strategy i NPOI & SystemData 11/16/201712:20 ..  Compress
@ Onelrive
[ This PC
[ Desktop
|£:-'] Documents
[ I PSS i S o
i File name: | NPOI & SystemData V| MinjaScript Archive File =

I o |

NinjaTrader successfully imported the required DLL files!... To continue, click OK.
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MW Control Center - Untitled1 — O b

File Tools Help [+/-] Open Live Account

Orders Strategies  Executions Postions  Accourts  Account Peformance  Log

Strateg‘,' nede Dzt Sa D Doniti Mun llnras Baali A =+ Connect Enable
Impert MinjaScript Archive File (zip) x

MinjaTrader successfully impoerted all indicators/strategies contained in the
Minja5cript Archive File.

4, Strategy Compatibility Tool in Ninja Strategy Performance Module

The purpose is to make your open-source Strategy for NinjaTrader 7 compatible to Ninja
Strategy Loader in just one go.

Open Ninja Strategy Loader. Go to Help, then select Strategy Compatibility Tool.

&2 Ninja Strategy Loader — O >

File | Help

Deactivate

CAN Activate
Strategy Compatibility Tool

Source
(xls) Column:

Parameters ) GO .es

Optimize data series Replay

Next :

Move previous |0 of 0 | » Move next

Status: Licensed and activated for Minja Strategy Loader

Browse your open source code file Strategy, select the file and click Open to continue.

& - O X
File  Help
&7 Open X
4N <« bin » Custom » Strategy v @ Search Strategy r
Organize + Mew folder = @ @
Strateg) pati ~ F O x
I This PC MName Date modified Type
Make your Str{ oy
yeu [ Desktop | @Strategy 3/13/2017 %34 AM - CSFile
BROWSE I: @ Documents j MACrossOver C5 File :I
* Downloads Mj UserDefinedMethods C5File
J‘s Music IER
| Pictures E
B videos e BB

File name: | MACrossOver

Status: Licensed and activated for Ninja Strategy Loader
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Click Update with Strategy Loader to continue.

File Help

CA\
Table:

aal

Make your Strategy compatible to Ninja Strategy Loader

e

Successfully updated.

BROWSE l(i\_User‘s \_Iﬁ\pﬂme nts\NinjaTrader ?\_bﬂ\ CusTan'.n\Swﬂtegy} MACrossOver.cs

UPDATE WITH STRATEGY LOADER REMOVE STRATEGY LOADER

File Help

CA\\
Table:

Make your Strategy compatible to Ninja Strateg

BROWSE

C:\Users\Ruel\Documents\NinjaTrader

UPDATE WITH STRATE!

l I I

egy\MACrossOver.cs

Done!

5. Compiling

REMOVE STRATEGY LOADER

Go to Control Center, Click Tools > Edit NinjaScript > then select Strategy.

W Control Center - Untitled1

File | Tools | Help  [+/-]

Orders| &1
e

Instrument Manager...
Histerical Data Manager...

- [m] x

Open Live Account

nts  Account Peformance  Log

Options...

Account Connections...

Parameters

T Session Manager...

F|  Hot Key Manager...

& New NinjaScript »
[S Edit NinjaScript » | k5] Indicator...

%  Output Window... [s] Strategy... ]
]

]

Po Av Un Reali Account Conne

Select the file, then click OK to continue.

Enabled
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w t| M Edit Strategy x x
File Tools en Live Account
T 8 UserDefinedMethods -
Statey [ Ensbled

-

. = - -

1

Right click and select compile.

.| Strategy - MACrossOver - O x
HAQ P ¥h@X 9o NEiEe|= 2

Save F4
Save As...
Do o  Compile Fs
Insert Code Snippet F2
Go To Line... Ctrl+G

Insert Action...

Insert Condition...
rategy.

EStratHelper UnDe
ReDo

Cut
Copy
Paste
Delete

Select All

Orange; Debug Mode
= color.Green;  [[F] iniine SyntaxChecking bl
Font...

References..

After compiling, your Strategy should now be compatible to Ninja Strategy Loader

The following are examples and explanation on Ninja Strategy Performance

Step by step process on how to use Ninja Strategy Loader

1. Optimization. Please run Optimization in Strategy Analyzer and Save Optimization Results.

Select instrument and make sure to set “keep best # results” you wish to optimize.

a. Setup connection

e Go to File > Connect > Kinetic

b. Setup Strategy Analyzer

e Go to File > New > Strategy Analyzer
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W Control Center - Untitled — | *
File | Tools  Help Dpen Live Sccount
| M e BT Alerts.. Log
T Workspaces v |B  Basic Entry.. Slize  Account Connect Enabl
§ Connect y |29 Chart.,
= Discannect v | Dynamic SuperDOM...
F F¥ Pro..
Flatten Evergthing o
[ Lewel ..,
AU (e harket fnalyzer..
Global Simulation Mode = s
W Utilities b O[] Static SuperDOM..,
4 Exit _,El Strate gy Analyzer...
i

|| Connected - Kinetick. |

e Selectinstrument and click Optimizer on the top left button. Set parameters Minimum and
Maximum range as well as the Increment, then Run Optimization.

45 Strategy Analyzer =] x
@E 2 EEE »ms Percent v
_ ;._l I;szn ‘T fly> Summary Chart Graphs Executions Trades Periods Orders Settings 8 ]
= | aul
@ GC 1217 Performance All Trades Strategy: MACrossOver o
@® (3 pow 30 Total Net Profit $0.00 =
# (@] FOREX Gross Profit $0.00 e A3 g
@ % gggDm 100 Gross Loss $0.00 = P
5 (] SP 500 Commission 50.00 B Fast 2:6:1
@ [8) Sirategies Profit Factor 1.00 Slow 10:10:1
Cumulative Profit 0.00% =) ':;"‘::':: 5
nce 1S on
% Last
Max. Drawdqwn 0.00! Tyoe F =
Shiacpie Rali 100 Bl Value 4:8:1
B Timetram
Start Date 4/13/2006 From 11/1372017
End Date 4/13/2006 To 1171572017
Session template <Use instrument settings
B General
o ol Tades 0 Include commissicn False
Percent Profitable 0.00% Label MACrossOver
# of Winning Trades 0 Maximum bars look back TwoHundredFiftySix
# of Losing Trades 0 Min. bars required 20
Bl Historical Fill Processing
Average Trade 0.00% ;::' type OD"""“
Average Winning Trade 0.00% B Optims
Average Losing Trade 0.00% Keep best # results 10
Ratio avg. Win / avg. Loss 0.00 Optimize data series True
| Optimize on... ‘max. profit factor M
Max. conseq. Winners 0 L""T .
Mox: comeg Lovers o Simple moving average cross over sirategy.
Largest Winning Trade 0.00%
Largest Losing Trade 0.00% Run Optimization I

Optimizer tab, right click on results ->Grid ->Export to Excel.

o2undo

e Save
the
results —
Go to

e Insert “StrategylD” column in your excel and fill in series. This will be a unique ID

Of every strategy. Then, save.
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MACrossOwver Optimization Results [Compatibility Mode] - E

HOME | INSERT  PAGELAYOUT  FORMULAS  DATA  REVIEW  VIEW
= 96 Cut Microscft Sans Se - |8 A A = = | &~ = Wrap Text :General -
- Em Copy ~ bl
Has = = = = 3= 1 B
FESE _op FormatPsinter | B T U - | E~ H- A~ === &=3= ElMerge&Center -~ $ ~ % » %8 8
Clipboard ] Font = Alignment = Number =
B2 5| Jx | max
| A B ] c D E F G H | J ; K L |
1 | Instrument | StrategylD |Perfformance] Parameters [otal Met Profl Gross Profit | Gross Loss | Profit Factorpmulative Prdax. Drawdovital £ of Tradprcent Profitable
2 GC 1217 MA1 10.95 leriod /Fast /5 2190 2410 -220 10.954545 | 0.0172086 | -0.00077 12 0.6666667
3 | GC 12117 mA2 8.34  |erod/Fast/5| 2130 2420 290 83448276 | 0.0167249 | -0.000933 12 0.5833333
4 GC 1217 MA3 3 eriod /Fast /S| 2350 2820 -470 6 0.0184507 | -0.001409 16 0.6875
5 | GC 1217 MAs 5.48 erod/Fast/S| 1970 2410 440 5.4772727 | 0.0154447 | -0.001328 1 0.4545455
6 GC 1217 MAS 5.06 eriod /Fast /5| 2110 2630 -520 5.0576923 | 0.0165794 | -0.00172 15 0.6
7 | GC 127 MAG 5.02 enod/Fast/5| 2170 2710 -540 5.0185185 | 0.0170591 | -0.00139% 20 06
8 | GC 12117 MAT 496  |enod/Fast/S| 13940 2430 -450 49591837 | 0.0152047 | -0.001433 1" 0.5454545
9 GC 1217 MASB 4.9 'eriod /Fast/§ 2030 2550 520 45038462 | 0.0159438 | -0.001407 15 0.6
10| GC 1217 MAS 4.22  prod/Fast/S| 2220 2910 -590 4.2173913 | 0.0174627 | -0.001717 20 06
11 ] GC 1297 MA10 414 knodz?ams 1790 2360 -570 4.1403509 | 0.0140169 | -0.001728 1 0.45454585
12 -
13 | L
14 |
15 |
16 |
17 |
18 |
19|
20 |
21

2. Open Ninja Strategy Loader

a. Load Excel File resulted from optimization

Condition
Formatting

M

=P

e Load the Excel file by clicking the Source (xIs) button, then find your excel file, and
click open.

e Tools

Help

Orders Strategies

Instru

Status: Licensed and activated for Ni njc-‘-i-trategy Loader

Ie? Ninja Strategy Loader — O Fil
@ Open
4 B » ThisPC » Desktop v O Search Desktop L
Organize « New folder =~ M O
B This PC Name Date modified Type
I Desktop 7 Google Chrome 10/7/20179:52 AM  Shortcut
4] Documents B9 | MACrossOver Optimization Results 11/16/2017 7:28 PM  Microsof
& Downloads #V NinjaTrader 7 (64-bit) 11/12/2017 2:29PM  Shortcut
D Msi aﬂeplay[}ataRequest 12/16/2016 10:07 ...  Applicati
usic
[&=] Pictures
B videos
B Windows Phone , g h, >
File name: | MACrossOver Optimization Results v I
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e Select your Strategy.

& Minja Strategy Loader

File Help
C:\Users\Ruel\Desktop\MACrossOver Optimization Results.xls . You
Table: can also jump
Sheetl$ to specific
Source e rows by typing
Column: the number in
the box
i i GO v between Move
previous and
Move next.
MACrossOver xml

Next : 8/5/18/MA3 (Period/Fast/Slow/ StrategyID)

{ Move previous |1 of 10 P Move next

Status: Licensed and activated for Ninja Strategy Loader

e Optimize data series. Leave it check to optimize data series.

Qj Ninja Strategy Loader

File Help

C:\Users\Ruel\Desktop\MACrossOver Optimization Results.xls
Table:
|Sheetl$ ~|

Source
(xl=) Column:

[Par'arnefer's Vl Go csse

ptimize data g&les Replay
FAC!‘ ossOver . xml I ~ |

Mmal

Next : 8/5/18/MA3 (Period/Fast/ Slow/ StrategyID)

Move previous |1 of 10 P Move next

Status: Licensed and activated for Ninja Strategy Loader

¢ If you are running Market Replay, please check Replay box.

¢ Go button — Click go to load data. (Then, it automatically moves on the next
Strategy.
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&2 Ninja Strategy Loader = O X

File  Help

C:\Users\Ruel\Desktop\MACrossOver Optimization Results.xls

Table:
Source Shest -
(xls) Column:
Parameters v Go e
1 Optimize data series Replay N
MACrossOver.xml v
MA2

Next : 8/6/18/MA3 (Period/Fast/Slow/ StrategyID)

- 4 Move previous 2 of 10 » Move next l

Status: Licensed and activated for Ninja Strategy Loader

e Go to NinjaTrader Control Center - Right click on Strategies tab. Click New Strategy, then
click OK.

W Control Center - Untitled1 s O X

@ Minja Strategy Loader

File Tools Help [+/-] Open Live Account

File Help Orders Strategies Executions Postions Accounts Account Pefomance Log
Strategy © Instrum Data S Parameters Position Avg Unre Real Account Conne Enabled
C:\Users\Ruel\Desktop\MACrossOver Optimization Results.xls
Table:
Source '5hz2ﬂ$ VI
(xls) Column: Wew Strategy...
Ml Strategy...
|Par-ameters vl o L ote
L | Enable
[ Optimize data series 1 Replay Disable
|MACmssOvem<ml v] ‘ Removh
Strategy Performance »
MA2 " =
tmte Replay (pa Filter Only Active Strategies
Next:  8/6/18/MA3 (Period/Fast/Slow/ StrategyID) [ | Fhefhccount i
! NinjaScript C[ T Grid »
4 Move previous 2 of 10 | b Move next NJATHAE ' | I |

Status: Licensed and activated for Ninja Strategy Loader
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New Strategy
enter - Up Strategy: MACrossOver ~
& Ninja Strategy Loader — o] File Teols Help B .. Open Live Account
3 Account Name MA4 | LA
File Help Orders Strategies  Exegy
Strategy ¥ lnstnmi Fast rd iount Conne Enabled
C:\Users\Ruel\Desktop\MACrossOver Optimization Results.xls MACross | GC 12~'a Slow 18 play | Market
Table: MACross | GC 12 Phioo tesed o Liiat play | Market
MACross | GC 12+ Type MeanRenko play | Market
Seurce sheet$ - Erick size 8
Instrument(s) GC 12-17
(xls) Column: B Time frame.
-~ ‘s Days to load 40
[Parameters | o 5 Session template <Use instrument settings>
o : B General
Optimize data series Replay {[Connected - Replay | Account Replay 101
[MACrossOver xmi ] "] Calculateonbarclose  True
MACrossOver
MAS y Maximum bars lock back  TwoHundredFiftySix
11/13/2017 12:59:53 PM
Next : 7/9/18/MA3 (Period/Fast/Slow/ Strategyl
ol ¢ Fast/ Slovy! B From [1/13/2017 @~ ]| 1o [11152017 @~ |
NinjaScript e |
| |
4 Move previous 5 of 10 | b Move next \JATRAH’" » o
Status: Licensed and activated for Ninja Strategy Loader E"‘t on close True
Exit on close seconds 1440

Stop & target submission  PerEntry Execution
S nt poeiti Ealea.

Label

Simple moving average cross over strategy.

Conesl |

b. Load each values. Repeat the process...

¢ Click Go button on Ninja Strategy Loader.
¢ Right click on Strategies tab.

¢ New Strategy

e Click OK or press Enter key.

M Control Center - Untitled1 - a X
& Ninja Str File Tools Help [+/-] Open Live Account
File  Help Orders  Strategies Executions Postions Accounts Account Peformance  Log
Strategy © Instrum Data S Parameters Position Avg Unre Real Account Conne Enabled
C:\Users\Ruel\Desktop\MACrossOver Optimization Results.xls MACross | GC 12-| 8 Mea | &/518/MA1 (Period/ - 0 | 500 50. | Replay | Market| [
Table: MACross | GC 12- | 8 Mea | S/6/190AD (Period) | - 0 | $00 | S0, | Repiay | Market| [ ]
MACross | GC 12- | 7 Mea | 7/8118MMA3 (Period/ - 0 | 500] $0. | Replay [ Market| []
Finnes ISheefl$ v] MACross | GC 12- | 8Mea | &718/MA4 (Period/ | - 0 | S0.0] S0. | Replay | Market| [J
{ Column: MACross | GC12-| 7Mea | 7/91&MAS (Period/ | - | 0 [ 50.0] SO. | Replay [ Market| [J
(xs) e MACross | GC 12-| 7Mea | 7/7/18MAG (Period/ | - | 0 | S0.0] SO. | Replay | Market| [J
Parameters - GO._. MACross | GC 12- | 8 Mes | BRTBNAT (Periodl | - | 0 | S0.0 S0, | Replay | Market| [
MACross | GC 12- | 7 Mea | 7/10/18/MAB (Period/ | - 0 | 50.0| 50 | Replay | Market| [J
[4 Optimize data series [ Replay MACross | GC 12- | 7 Mea | 7/6/18/MAS (Period/ | - 0 | 50.0| $0. | Replay | Market| L[]
IM ACrossOversanl \.] MACross | GC 12- | 8 Mea | 8/B/18/MATD (Period/ | - 0 | s0.0] s0. | Replay [ Market| [J
MA10 i

Replay (paused 372017 12:5%:53 PM

Next : 8/8/18/MA3 (Period/Fast/ Slow/ StrategyID) b [[T9807 B7] 1e [8ET 5]

NinjaScript

4 Move previous 10 of 10 F Move next ‘ JATHA&’ I »|'

Status: Licensed and activated for Ninja Strategy Loader




